From: Sascha Hauer <s.hauer@pengutronix.de>
To: barebox@lists.infradead.org
Subject: [PATCH 14/16] of: rename new_device_node to of_new_node and export it
Date: Fri, 11 Jan 2013 14:24:34 +0100 [thread overview]
Message-ID: <1357910676-4231-15-git-send-email-s.hauer@pengutronix.de> (raw)
In-Reply-To: <1357910676-4231-1-git-send-email-s.hauer@pengutronix.de>
of_new_node now takes the parent node and the name as argument and
creates a new node. This simplifies the caller and also makes the
function useful for others, so export it.
Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
---
drivers/of/base.c | 24 +++++++++++++++++-------
include/of.h | 1 +
2 files changed, 18 insertions(+), 7 deletions(-)
diff --git a/drivers/of/base.c b/drivers/of/base.c
index 5910b40..c9e93f6 100644
--- a/drivers/of/base.c
+++ b/drivers/of/base.c
@@ -585,18 +585,33 @@ void of_print_nodes(struct device_node *node, int indent)
printf("};\n");
}
-static struct device_node *new_device_node(struct device_node *parent)
+struct device_node *of_new_node(struct device_node *parent, const char *name)
{
struct device_node *node;
+ if (!parent && root_node)
+ return NULL;
+
node = xzalloc(sizeof(*node));
node->parent = parent;
if (parent)
list_add_tail(&node->parent_list, &parent->children);
+ else
+ root_node = node;
INIT_LIST_HEAD(&node->children);
INIT_LIST_HEAD(&node->properties);
+ if (parent) {
+ node->name = xstrdup(name);
+ node->full_name = asprintf("%s/%s", node->parent->full_name, name);
+ } else {
+ node->name = xstrdup("");
+ node->full_name = xstrdup("");
+ }
+
+ list_add_tail(&node->list, &allnodes);
+
return node;
}
@@ -886,12 +901,7 @@ int of_unflatten_dtb(struct fdt_header *fdt)
if (n) {
node = n;
} else {
- node = new_device_node(node);
- if (!node->parent)
- root_node = node;
- node->full_name = xstrdup(buf);
- node->name = xstrdup(pathp);
- list_add_tail(&node->list, &allnodes);
+ node = of_new_node(node, pathp);
}
break;
case FDT_END_NODE:
diff --git a/include/of.h b/include/of.h
index e53f94c..ea23d85 100644
--- a/include/of.h
+++ b/include/of.h
@@ -108,6 +108,7 @@ int of_parse_dtb(struct fdt_header *fdt);
void of_free(struct device_node *node);
int of_unflatten_dtb(struct fdt_header *fdt);
void *of_flatten_dtb(void);
+struct device_node *of_new_node(struct device_node *parent, const char *name);
struct property *of_new_property(struct device_node *node, const char *name,
const void *data, int len);
void of_delete_property(struct property *pp);
--
1.7.10.4
_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox
next prev parent reply other threads:[~2013-01-11 13:24 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-01-11 13:24 [PATCH] devicetree improvements Sascha Hauer
2013-01-11 13:24 ` [PATCH 01/16] of: make of_get_fixed_tree more universally usable Sascha Hauer
2013-01-11 13:24 ` [PATCH 02/16] of: Fix invalid path for of_find_node_by_path Sascha Hauer
2013-01-11 13:24 ` [PATCH 03/16] ARM android image: remove double of_fix_tree Sascha Hauer
2013-01-11 13:24 ` [PATCH 04/16] of: of_free fixes Sascha Hauer
2013-01-11 13:24 ` [PATCH 05/16] of of_free: remove old node from allnodes list Sascha Hauer
2013-01-11 13:24 ` [PATCH 06/16] of: return root node when looking for a node with path / Sascha Hauer
2013-01-11 13:24 ` [PATCH 07/16] of: rename of_parse_dtb to of_unflatten_dtb Sascha Hauer
2013-01-11 13:24 ` [PATCH 08/16] of: Add support for converting the unflattened tree back to a dtb Sascha Hauer
2013-01-11 13:24 ` [PATCH 09/16] of: remove unused barebox_fdt Sascha Hauer
2013-01-11 13:24 ` [PATCH 10/16] ARM bootm: only use concatenated oftree when no other is available Sascha Hauer
2013-01-11 13:24 ` [PATCH 11/16] of: unflatten: allow overlay dtbs Sascha Hauer
2013-01-11 13:24 ` [PATCH 12/16] oftree command: refactor Sascha Hauer
2013-01-11 13:24 ` [PATCH 13/16] of: add of_delete_property Sascha Hauer
2013-01-11 13:24 ` Sascha Hauer [this message]
2013-01-11 13:24 ` [PATCH 15/16] commands: Add of_property command Sascha Hauer
2013-01-11 13:24 ` [PATCH 16/16] commands: Add of_node command Sascha Hauer
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1357910676-4231-15-git-send-email-s.hauer@pengutronix.de \
--to=s.hauer@pengutronix.de \
--cc=barebox@lists.infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox