mail archive of the barebox mailing list
 help / color / mirror / Atom feed
* [PATCH] ddr: imx: rename ddr_get_firmware_ddr to ddr_get_firmware_ddr4
@ 2024-05-15 11:00 Ahmad Fatoum
  2024-05-16  6:09 ` Sascha Hauer
  0 siblings, 1 reply; 2+ messages in thread
From: Ahmad Fatoum @ 2024-05-15 11:00 UTC (permalink / raw)
  To: barebox; +Cc: Ahmad Fatoum

The omission of the 4 was likely a typo. Adding it makes it clearer what
the function does and serves symmetry with ddr_get_firmware_lpddr4().

Signed-off-by: Ahmad Fatoum <a.fatoum@pengutronix.de>
---
 drivers/ddr/imx/ddrphy_train.c | 2 +-
 include/soc/imx/ddr.h          | 4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/ddr/imx/ddrphy_train.c b/drivers/ddr/imx/ddrphy_train.c
index d599445e6f57..24997a6f3667 100644
--- a/drivers/ddr/imx/ddrphy_train.c
+++ b/drivers/ddr/imx/ddrphy_train.c
@@ -40,7 +40,7 @@ static size_t ddr4_imem_2d_size;
 static const u16 *ddr4_dmem_2d;
 static size_t ddr4_dmem_2d_size;
 
-void ddr_get_firmware_ddr(void)
+void ddr_get_firmware_ddr4(void)
 {
 	get_builtin_firmware(ddr4_imem_1d_bin, &ddr4_imem_1d,
 			     &ddr4_imem_1d_size);
diff --git a/include/soc/imx/ddr.h b/include/soc/imx/ddr.h
index caf33d3e34b9..1e64613895d1 100644
--- a/include/soc/imx/ddr.h
+++ b/include/soc/imx/ddr.h
@@ -114,14 +114,14 @@ struct dram_controller {
 };
 
 void ddr_get_firmware_lpddr4(void);
-void ddr_get_firmware_ddr(void);
+void ddr_get_firmware_ddr4(void);
 
 static inline void ddr_get_firmware(enum dram_type dram_type)
 {
 	if (dram_type == DRAM_TYPE_LPDDR4)
 		ddr_get_firmware_lpddr4();
 	else
-		ddr_get_firmware_ddr();
+		ddr_get_firmware_ddr4();
 }
 
 int ddr_cfg_phy(struct dram_controller *dram, struct dram_timing_info *timing_info);
-- 
2.39.2




^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PATCH] ddr: imx: rename ddr_get_firmware_ddr to ddr_get_firmware_ddr4
  2024-05-15 11:00 [PATCH] ddr: imx: rename ddr_get_firmware_ddr to ddr_get_firmware_ddr4 Ahmad Fatoum
@ 2024-05-16  6:09 ` Sascha Hauer
  0 siblings, 0 replies; 2+ messages in thread
From: Sascha Hauer @ 2024-05-16  6:09 UTC (permalink / raw)
  To: barebox, Ahmad Fatoum


On Wed, 15 May 2024 13:00:37 +0200, Ahmad Fatoum wrote:
> The omission of the 4 was likely a typo. Adding it makes it clearer what
> the function does and serves symmetry with ddr_get_firmware_lpddr4().
> 
> 

Applied, thanks!

[1/1] ddr: imx: rename ddr_get_firmware_ddr to ddr_get_firmware_ddr4
      https://git.pengutronix.de/cgit/barebox/commit/?id=81c131efcaa5 (link may not be stable)

Best regards,
-- 
Sascha Hauer <s.hauer@pengutronix.de>




^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2024-05-16  6:10 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-05-15 11:00 [PATCH] ddr: imx: rename ddr_get_firmware_ddr to ddr_get_firmware_ddr4 Ahmad Fatoum
2024-05-16  6:09 ` Sascha Hauer

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox