mail archive of the barebox mailing list
 help / color / mirror / Atom feed
From: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
To: Alexander Shiyan <shc_work@mail.ru>
Cc: barebox@lists.infradead.org
Subject: Re: [PATCH 4/5] GPIO: i.MX: Cleanup driver code
Date: Sat, 20 Apr 2013 19:04:02 +0200	[thread overview]
Message-ID: <20130420170402.GA13393@game.jcrosoft.org> (raw)
In-Reply-To: <1366431532-29121-5-git-send-email-shc_work@mail.ru>

On 08:18 Sat 20 Apr     , Alexander Shiyan wrote:
> This patch provides only cleanup for i.MX GPIO driver.
> Indentation, reduced licence text etc.
no please drop it this is just noise on the history when doing blame
> 
> Signed-off-by: Alexander Shiyan <shc_work@mail.ru>
> ---
>  drivers/gpio/gpio-imx.c | 34 ++++++++++++----------------------
>  1 file changed, 12 insertions(+), 22 deletions(-)
> 
> diff --git a/drivers/gpio/gpio-imx.c b/drivers/gpio/gpio-imx.c
> index 9dcabfc..f56346b 100644
> --- a/drivers/gpio/gpio-imx.c
> +++ b/drivers/gpio/gpio-imx.c
> @@ -1,23 +1,14 @@
>  /*
> - *  arch/arm/mach-imx/gpio.c
> + *  GPIO driver for i.MX machines
>   *
>   *  author: Sascha Hauer
>   *  Created: april 20th, 2004
>   *  Copyright: Synertronixx GmbH
>   *
> - *  Common code for i.MX machines
> - *
>   * This program is free software; you can redistribute it and/or modify
>   * it under the terms of the GNU General Public License as published by
>   * the Free Software Foundation; either version 2 of the License, or
>   * (at your option) any later version.
> - *
> - * This program is distributed in the hope that it will be useful,
> - * but WITHOUT ANY WARRANTY; without even the implied warranty of
> - * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
> - * GNU General Public License for more details.
> - *
> - *
>   */
>  
>  #include <init.h>
> @@ -33,15 +24,15 @@ struct imx_gpio_regs {
>  };
>  
>  static struct imx_gpio_regs regs_imx1 = {
> -	.dr = 0x1c,
> -	.gdir = 0x00,
> -	.psr = 0x24,
> +	.dr	= 0x1c,
> +	.gdir	= 0x00,
> +	.psr	= 0x24,
>  };
>  
>  static struct imx_gpio_regs regs_imx31 = {
> -	.dr = 0x00,
> -	.gdir = 0x04,
> -	.psr = 0x08,
> +	.dr	= 0x00,
> +	.gdir	= 0x04,
> +	.psr	= 0x08,
>  };
>  
>  static int imx_gpio_probe(struct device_d *dev)
> @@ -128,15 +119,14 @@ static struct platform_device_id imx_gpio_ids[] = {
>  };
>  
>  static struct driver_d imx_gpio_driver = {
> -	.name = "imx-gpio",
> -	.probe = imx_gpio_probe,
> -	.of_compatible = DRV_OF_COMPAT(imx_gpio_dt_ids),
> -	.id_table = imx_gpio_ids,
> +	.name		= "imx-gpio",
> +	.probe		= imx_gpio_probe,
> +	.of_compatible	= DRV_OF_COMPAT(imx_gpio_dt_ids),
> +	.id_table	= imx_gpio_ids,
>  };
>  
>  static int imx_gpio_add(void)
>  {
> -	platform_driver_register(&imx_gpio_driver);
> -	return 0;
> +	return platform_driver_register(&imx_gpio_driver);
>  }
>  coredevice_initcall(imx_gpio_add);
> -- 
> 1.8.1.5
> 
> 
> _______________________________________________
> barebox mailing list
> barebox@lists.infradead.org
> http://lists.infradead.org/mailman/listinfo/barebox

_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox

  reply	other threads:[~2013-04-20 17:08 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-04-20  4:18 [PATCH 1/5] GPIO: Rename "drivers/gpio.c" to "drivers/gpiolib.c" Alexander Shiyan
2013-04-20  4:18 ` [PATCH] ubimkvol: Typo fix Alexander Shiyan
2013-04-20  4:18 ` [PATCH 2/5] ARM: i.MX: Move GPIO driver to drivers/gpio Alexander Shiyan
2013-04-20  4:18 ` [PATCH 3/5] GPIO: i.MX: Rewrite driver for using generic GPIO code Alexander Shiyan
2013-04-22  6:46   ` Sascha Hauer
2013-04-22  6:59     ` Re[2]: " Alexander Shiyan
2013-04-22  7:21       ` Sascha Hauer
2013-04-22  9:23         ` Re[2]: " Alexander Shiyan
2013-04-20  4:18 ` [PATCH 4/5] GPIO: i.MX: Cleanup driver code Alexander Shiyan
2013-04-20 17:04   ` Jean-Christophe PLAGNIOL-VILLARD [this message]
2013-04-22 16:58   ` Sascha Hauer
2013-04-20  4:18 ` [PATCH 5/5] Introduce coredevice_platform_driver() macro and use it for GPIO drivers Alexander Shiyan
2013-04-22 16:59 ` [PATCH 1/5] GPIO: Rename "drivers/gpio.c" to "drivers/gpiolib.c" Sascha Hauer

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20130420170402.GA13393@game.jcrosoft.org \
    --to=plagnioj@jcrosoft.com \
    --cc=barebox@lists.infradead.org \
    --cc=shc_work@mail.ru \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox