mail archive of the barebox mailing list
 help / color / mirror / Atom feed
From: Sascha Hauer <s.hauer@pengutronix.de>
To: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
Cc: barebox@lists.infradead.org
Subject: Re: [PATCH 2/8] console: factorise function to get the console by name
Date: Mon, 7 Oct 2013 08:23:04 +0200	[thread overview]
Message-ID: <20131007062304.GR30088@pengutronix.de> (raw)
In-Reply-To: <20131006183856.GS32444@ns203013.ovh.net>

On Sun, Oct 06, 2013 at 08:38:56PM +0200, Jean-Christophe PLAGNIOL-VILLARD wrote:
> On 13:24 Sun 06 Oct     , Sascha Hauer wrote:
> > On Thu, Oct 03, 2013 at 09:21:54AM +0200, Jean-Christophe PLAGNIOL-VILLARD wrote:
> > > rename it to console_get_by_name
> > > 
> > > Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
> > > ---
> > > +struct console_device *console_get_by_name(const char *cname)
> > > +{
> > > +	struct console_device *cdev;
> > > +	const char *target;
> > > +
> > > +	for_each_console(cdev) {
> > > +		target = dev_id(&cdev->class_dev);
> > > +		if (strcmp(cname, target))
> > > +			continue;
> > > +		if ((cdev->f_active & (CONSOLE_STDIN | CONSOLE_STDOUT))
> > > +			return cdev;
> > > +		return NULL;
> > > +	}
> > > +	return NULL;
> > > +}
> > > +EXPORT_SYMBOL(console_get_by_name);
> > 
> > I think this function should return the console regardless of whether
> > it's active or not. This makes the console_get_by_name_flags you
> > introduce later unnecessary. Also the loadxyz code shouldn't care if
> > it's activated but instead just activate the console if necessary.
> 
> agreed that's why I change this in patch 5
> as now the loadxyz just check if the cdev support input and output
> and not if active or not

Ok, I somewhat misread the patch. I still think though that a function

struct console_device *console_get_by_name(const char *cname, int flags);

is a bit unclear. This function should either return the cdev by name
*or* check the flags, but not both,

The loadxy code now ends up with:

	if (cname)
		cdev = console_get_by_name(cname, CONSOLE_STDIN & CONSOLE_STDOUT);
	else
		cdev = console_get_first_active();

So if cname is given you explicitly ask for a console capable of input
*and* output. If not, you ask for the first actve console, that is the
first console which has input *or* output activated.

The loadxy code should rather look like:

	if (cname)
		cdev = console_get_by_name(cname);
	else
		cdev = console_get_first_active();

	if (!cdev)
		barf_and_bail_out;

	if (!console_can_do_input(cdev) || !console_can_do_output())
		barf_and_bail_out;


Sascha

-- 
Pengutronix e.K.                           |                             |
Industrial Linux Solutions                 | http://www.pengutronix.de/  |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |

_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox

  reply	other threads:[~2013-10-07  6:23 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-10-03  7:17 [PATCH 0/8 v2] more serial cleanup Jean-Christophe PLAGNIOL-VILLARD
2013-10-03  7:21 ` [PATCH 1/8] console: factorise function to get the first enabled console Jean-Christophe PLAGNIOL-VILLARD
2013-10-03  7:21   ` [PATCH 2/8] console: factorise function to get the console by name Jean-Christophe PLAGNIOL-VILLARD
2013-10-06 11:24     ` Sascha Hauer
2013-10-06 18:38       ` Jean-Christophe PLAGNIOL-VILLARD
2013-10-07  6:23         ` Sascha Hauer [this message]
2013-10-03  7:21   ` [PATCH 3/8] console: introduce startup and shutdown Jean-Christophe PLAGNIOL-VILLARD
2013-10-03  7:21   ` [PATCH 4/8] loadxy: use console_open/close Jean-Christophe PLAGNIOL-VILLARD
2013-10-03  7:21   ` [PATCH 5/8] console: console_get_by_name pass flags Jean-Christophe PLAGNIOL-VILLARD
2013-10-03  7:21   ` [PATCH 6/8] animeo_ip: update to use console_open/close for rs485 crossed detection Jean-Christophe PLAGNIOL-VILLARD
2013-10-03  7:21   ` [PATCH 7/8] serial: amba-pl011: add start and shutdown support Jean-Christophe PLAGNIOL-VILLARD
2013-10-03  7:22   ` [PATCH 8/8] serial: atmel: " Jean-Christophe PLAGNIOL-VILLARD

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20131007062304.GR30088@pengutronix.de \
    --to=s.hauer@pengutronix.de \
    --cc=barebox@lists.infradead.org \
    --cc=plagnioj@jcrosoft.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox