mail archive of the barebox mailing list
 help / color / mirror / Atom feed
From: Andrey Smirnov <andrew.smirnov@gmail.com>
To: barebox@lists.infradead.org
Cc: Andrey Smirnov <andrew.smirnov@gmail.com>
Subject: [PATCH v3 12/22] drivers: base: Convert device_d name to be dynamically allocated
Date: Sun, 14 Oct 2018 19:21:15 -0700	[thread overview]
Message-ID: <20181015022125.24020-13-andrew.smirnov@gmail.com> (raw)
In-Reply-To: <20181015022125.24020-1-andrew.smirnov@gmail.com>

Convert device_d name to be dynamically allocated in order to lift
MAX_DRIVER_NAME length limit needed for commits that follow.

Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com>
---
 drivers/base/driver.c | 23 +++++++++++++++++------
 include/driver.h      |  5 ++---
 2 files changed, 19 insertions(+), 9 deletions(-)

diff --git a/drivers/base/driver.c b/drivers/base/driver.c
index b7720f31a..1941a972c 100644
--- a/drivers/base/driver.c
+++ b/drivers/base/driver.c
@@ -184,11 +184,9 @@ int register_device(struct device_d *new_device)
 	}
 
 	if (new_device->id != DEVICE_ID_SINGLE)
-		snprintf(new_device->unique_name,
-			 sizeof(new_device->unique_name),
-			 FORMAT_DRIVER_NAME_ID,
-			 new_device->name,
-			 new_device->id);
+		new_device->unique_name = basprintf(FORMAT_DRIVER_NAME_ID,
+						    new_device->name,
+						    new_device->id);
 
 	debug ("register_device: %s\n", dev_name(new_device));
 
@@ -478,16 +476,29 @@ EXPORT_SYMBOL(dummy_probe);
  * @dev: device
  * @fmt: format string for the device's name
  *
+ * NOTE: This function expects dev->name to be free()-able, so extra
+ * precautions needs to be taken when mixing its usage with manual
+ * assignement of device_d.name.
  */
 int dev_set_name(struct device_d *dev, const char *fmt, ...)
 {
 	va_list vargs;
 	int err;
+	/*
+	 * Save old pointer in case we are overriding already set name
+	 */
+	char *oldname = dev->name;
 
 	va_start(vargs, fmt);
-	err = vsnprintf(dev->name, sizeof(dev->name), fmt, vargs);
+	err = vasprintf(&dev->name, fmt, vargs);
 	va_end(vargs);
 
+	/*
+	 * Free old pointer, we do this after vasprintf call in case
+	 * old device name was in one of vargs
+	 */
+	free(oldname);
+
 	WARN_ON(err < 0);
 
 	return err;
diff --git a/include/driver.h b/include/driver.h
index 94fddc735..db844aed3 100644
--- a/include/driver.h
+++ b/include/driver.h
@@ -23,7 +23,6 @@
 #include <linux/ioport.h>
 #include <of.h>
 
-#define MAX_DRIVER_NAME		32
 #define FORMAT_DRIVER_NAME_ID	"%s%d"
 
 #include <param.h>
@@ -44,13 +43,13 @@ struct device_d {
 	 * should not be modified directly and dev_set_name() should
 	 * be used instead.
 	 */
-	char name[MAX_DRIVER_NAME];
+	char *name;
 
 	/*! This member is used to store device's unique name as
 	 *  obtained by calling dev_id(). Internal field, do not
 	 *  access it directly.
 	  */
-	char unique_name[MAX_DRIVER_NAME + 16];
+	char *unique_name;
 	/*! The id is used to uniquely identify a device in the system. The id
 	 * will show up under /dev/ as the device's name. Usually this is
 	 * something like eth0 or nor0. */
-- 
2.17.1


_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox

  parent reply	other threads:[~2018-10-15  2:22 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-10-15  2:21 [PATCH v3 00/22] MV88E6xxx switch family support Andrey Smirnov
2018-10-15  2:21 ` [PATCH v3 01/22] ARM: Do not expose ARMv8 functions on ARMv7 Andrey Smirnov
2018-10-15  2:21 ` [PATCH v3 02/22] clocksource: Add ARM global timer support Andrey Smirnov
2018-10-15 20:46   ` Sam Ravnborg
2018-10-15 21:27     ` Andrey Smirnov
2018-10-15  2:21 ` [PATCH v3 03/22] VFxxx: Select CLOCKSOURCE_ARM_GLOBAL_TIMER Andrey Smirnov
2018-10-15  2:21 ` [PATCH v3 04/22] i.MX: Move GPT driver to drivers/clocksource Andrey Smirnov
2018-10-15  2:21 ` [PATCH v3 05/22] clocksource: Introduce ARCH_HAS_IMX_GPT Andrey Smirnov
2018-10-15  2:21 ` [PATCH v3 06/22] of: Demote "Bad cell count for" to debug Andrey Smirnov
2018-10-15  2:21 ` [PATCH v3 07/22] aiodev: Don't try to use DT node name as aiodev->name Andrey Smirnov
2018-10-15  2:21 ` [PATCH v3 08/22] aiodev: imx_thermal: Give aiodev a more descriptive name Andrey Smirnov
2018-10-15  2:21 ` [PATCH v3 09/22] aiodev: qoriq_thermal: " Andrey Smirnov
2018-10-15  2:21 ` [PATCH v3 10/22] drivers: Introduce dev_set_name() Andrey Smirnov
2018-10-15  2:21 ` [PATCH v3 11/22] base: Don't use shared buffer for results of dev_id() Andrey Smirnov
2018-10-15  2:21 ` Andrey Smirnov [this message]
2018-10-15  2:21 ` [PATCH v3 13/22] linux: string: Port kbasename() Andrey Smirnov
2018-10-15  2:21 ` [PATCH v3 14/22] of: Port latest of_device_make_bus_id() implementation Andrey Smirnov
2018-10-15  2:21 ` [PATCH v3 15/22] mdio_bus: Fix documentation for mdio_bus_match() Andrey Smirnov
2018-10-15  2:21 ` [PATCH v3 16/22] include: linux: phy: Add missing PHY_INTERFACE_* constants Andrey Smirnov
2018-10-15  2:21 ` [PATCH v3 17/22] include: linux: ethtool: Add missing *_UNKNOWN constants Andrey Smirnov
2018-10-15  2:21 ` [PATCH v3 18/22] net: phy: Check phy_mask in get_phy_device() Andrey Smirnov
2018-10-15  2:21 ` [PATCH v3 19/22] mdio_bus: Allow for non PHY-devices on MDIO buses Andrey Smirnov
2018-10-15  2:21 ` [PATCH v3 20/22] net: phy: Add basic driver for MV88E6XXX switches from Marvell Andrey Smirnov
2018-10-15 21:19   ` Sam Ravnborg
2018-10-15 21:35     ` Andrey Smirnov
2018-10-16  5:46       ` Sam Ravnborg
2018-10-15  2:21 ` [PATCH v3 21/22] net: phy: mv88e6xxx: Port EEPROM support code Andrey Smirnov
2018-10-15  2:21 ` [PATCH v3 22/22] net: phy: mv88e6xxx: Add support for MAC ports Andrey Smirnov
2018-10-15  3:33 ` [PATCH v3 00/22] MV88E6xxx switch family support Andrey Smirnov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20181015022125.24020-13-andrew.smirnov@gmail.com \
    --to=andrew.smirnov@gmail.com \
    --cc=barebox@lists.infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox