mail archive of the barebox mailing list
 help / color / mirror / Atom feed
* [PATCH 1/6] mci: core: Use alias as a devname by default
@ 2018-12-07  7:33 Andrey Smirnov
  2018-12-07  7:33 ` [PATCH 2/6] mci: tegra-sdmmc: Drop explicit devname setup code Andrey Smirnov
                   ` (5 more replies)
  0 siblings, 6 replies; 7+ messages in thread
From: Andrey Smirnov @ 2018-12-07  7:33 UTC (permalink / raw)
  To: barebox; +Cc: Andrey Smirnov

This idiom is repeatead by almost every mci driver, so move it to
mci_of_parse() in order to reduce amount of duplicated code.

Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com>
---
 drivers/mci/mci-core.c | 5 +++++
 1 file changed, 5 insertions(+)

diff --git a/drivers/mci/mci-core.c b/drivers/mci/mci-core.c
index c8d1d5e16..3efd80a8a 100644
--- a/drivers/mci/mci-core.c
+++ b/drivers/mci/mci-core.c
@@ -1858,6 +1858,7 @@ void mci_of_parse_node(struct mci_host *host,
 {
 	u32 bus_width;
 	u32 dsr_val;
+	const char *alias;
 
 	if (!IS_ENABLED(CONFIG_OFDEVICE))
 		return;
@@ -1865,6 +1866,10 @@ void mci_of_parse_node(struct mci_host *host,
 	if (!host->hw_dev || !np)
 		return;
 
+	alias = of_alias_get(np);
+	if (alias)
+		host->devname = xstrdup(alias);
+
 	/* "bus-width" is translated to MMC_CAP_*_BIT_DATA flags */
 	if (of_property_read_u32(np, "bus-width", &bus_width) < 0) {
 		/* If bus-width is missing we get the driver's default, which
-- 
2.19.1


_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2018-12-10  9:03 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-12-07  7:33 [PATCH 1/6] mci: core: Use alias as a devname by default Andrey Smirnov
2018-12-07  7:33 ` [PATCH 2/6] mci: tegra-sdmmc: Drop explicit devname setup code Andrey Smirnov
2018-12-07  7:33 ` [PATCH 3/6] mci: dw_mmc: " Andrey Smirnov
2018-12-07  7:33 ` [PATCH 4/6] mci: omap_hsmmc: " Andrey Smirnov
2018-12-07  7:33 ` [PATCH 5/6] mci: imx-esdhc: " Andrey Smirnov
2018-12-07  7:33 ` [PATCH 6/6] mci: mxs: " Andrey Smirnov
2018-12-10  9:03 ` [PATCH 1/6] mci: core: Use alias as a devname by default Sascha Hauer

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox