From: Andrey Smirnov <andrew.smirnov@gmail.com>
To: barebox@lists.infradead.org
Cc: Andrey Smirnov <andrew.smirnov@gmail.com>
Subject: [PATCH 09/21] PCI: Store and reuse BAR offsets
Date: Wed, 9 Jan 2019 20:57:27 -0800 [thread overview]
Message-ID: <20190110045739.19399-10-andrew.smirnov@gmail.com> (raw)
In-Reply-To: <20190110045739.19399-1-andrew.smirnov@gmail.com>
Save and reuse BAR offsets in dedicated constants instead of repeating
the same expression multiple times. No functional change intended.
Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com>
---
drivers/pci/pci.c | 16 ++++++++--------
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/pci/pci.c b/drivers/pci/pci.c
index e57cc32c76..3e249abe4f 100644
--- a/drivers/pci/pci.c
+++ b/drivers/pci/pci.c
@@ -166,15 +166,17 @@ static void setup_device(struct pci_dev *dev, int max_bar)
cmd & ~(PCI_COMMAND_IO | PCI_COMMAND_MEMORY));
for (bar = 0; bar < max_bar; bar++) {
+ const int pci_base_address_0 = PCI_BASE_ADDRESS_0 + bar * 4;
+ const int pci_base_address_1 = PCI_BASE_ADDRESS_1 + bar * 4;
u32 orig, mask, size;
unsigned long flags;
const char *kind;
int r;
- pci_read_config_dword(dev, PCI_BASE_ADDRESS_0 + bar * 4, &orig);
- pci_write_config_dword(dev, PCI_BASE_ADDRESS_0 + bar * 4, 0xfffffffe);
- pci_read_config_dword(dev, PCI_BASE_ADDRESS_0 + bar * 4, &mask);
- pci_write_config_dword(dev, PCI_BASE_ADDRESS_0 + bar * 4, orig);
+ pci_read_config_dword(dev, pci_base_address_0, &orig);
+ pci_write_config_dword(dev, pci_base_address_0, 0xfffffffe);
+ pci_read_config_dword(dev, pci_base_address_0, &mask);
+ pci_write_config_dword(dev, pci_base_address_0, orig);
if (mask == 0 || mask == 0xffffffff) {
pr_debug("pbar%d set bad mask\n", bar);
@@ -214,8 +216,7 @@ static void setup_device(struct pci_dev *dev, int max_bar)
}
last[r] = ALIGN(last[r], size);
- pci_write_config_dword(dev, PCI_BASE_ADDRESS_0 + bar * 4,
- last[r]);
+ pci_write_config_dword(dev, pci_base_address_0, last[r]);
dev->resource[bar].flags = flags;
dev->resource[bar].start = last[r];
dev->resource[bar].end = dev->resource[bar].start + size - 1;
@@ -226,8 +227,7 @@ static void setup_device(struct pci_dev *dev, int max_bar)
if (mask & PCI_BASE_ADDRESS_MEM_TYPE_64) {
dev->resource[bar].flags |= IORESOURCE_MEM_64;
- pci_write_config_dword(dev,
- PCI_BASE_ADDRESS_1 + bar * 4, 0);
+ pci_write_config_dword(dev, pci_base_address_1, 0);
bar++;
}
}
--
2.20.1
_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox
next prev parent reply other threads:[~2019-01-10 4:58 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-01-10 4:57 [PATCH 00/21] PCI improvements Andrey Smirnov
2019-01-10 4:57 ` [PATCH 01/21] PCI: Switch to using %pa to print memory addresses Andrey Smirnov
2019-01-10 4:57 ` [PATCH 02/21] PCI: Replace last_* variables with an array Andrey Smirnov
2019-01-10 4:57 ` [PATCH 03/21] PCI: Consolidate limit/base settting code Andrey Smirnov
2019-01-10 4:57 ` [PATCH 04/21] PCI: Convert prescan_setup_bridge() to use a loop Andrey Smirnov
2019-01-10 4:57 ` [PATCH 05/21] PCI: Convert postscan_setup_bridge() " Andrey Smirnov
2019-01-10 10:09 ` Sascha Hauer
2019-01-10 19:16 ` Andrey Smirnov
2019-01-11 10:47 ` Sascha Hauer
2019-01-12 2:34 ` Andrey Smirnov
2019-01-10 4:57 ` [PATCH 06/21] PCI: Replace magic number in setup_device() Andrey Smirnov
2019-01-10 4:57 ` [PATCH 07/21] PCI: Remove superfluous parens " Andrey Smirnov
2019-01-10 4:57 ` [PATCH 08/21] PCI: Simplify resource setup code " Andrey Smirnov
2019-01-10 4:57 ` Andrey Smirnov [this message]
2019-01-10 4:57 ` [PATCH 10/21] PCI: Conver register_pci_controller() to use a loop Andrey Smirnov
2019-01-10 4:57 ` [PATCH 11/21] PCI: Remove unused variables/code Andrey Smirnov
2019-01-10 4:57 ` [PATCH 12/21] PCI: Make pci_scan_bus static Andrey Smirnov
2019-01-10 4:57 ` [PATCH 13/21] PCI: Drop "slots" from struct pci_bus Andrey Smirnov
2019-01-10 4:57 ` [PATCH 14/21] PCI: Drop "resources" " Andrey Smirnov
2019-01-10 4:57 ` [PATCH 15/21] PCI: Drop "name" " Andrey Smirnov
2019-01-10 4:57 ` [PATCH 16/21] PCI: Drop "ops" " Andrey Smirnov
2019-01-10 4:57 ` [PATCH 17/21] PCI: Drop "rom_address" from struct pci_dev Andrey Smirnov
2019-01-10 4:57 ` [PATCH 18/21] PCI: Simplify alloc_pci_dev() Andrey Smirnov
2019-01-10 4:57 ` [PATCH 19/21] PCI: Assume 1:1 mapping if .res_start callback is NULL Andrey Smirnov
2019-01-10 4:57 ` [PATCH 20/21] PCI: Convert ->res_start() to return resource_size_t Andrey Smirnov
2019-01-10 4:57 ` [PATCH 21/21] PCI: Consify pci_ops in struct pci_controller Andrey Smirnov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20190110045739.19399-10-andrew.smirnov@gmail.com \
--to=andrew.smirnov@gmail.com \
--cc=barebox@lists.infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox