mail archive of the barebox mailing list
 help / color / mirror / Atom feed
From: Sascha Hauer <s.hauer@pengutronix.de>
To: Andrey Smirnov <andrew.smirnov@gmail.com>
Cc: barebox@lists.infradead.org
Subject: Re: [PATCH 05/21] PCI: Convert postscan_setup_bridge() to use a loop
Date: Thu, 10 Jan 2019 11:09:20 +0100	[thread overview]
Message-ID: <20190110100920.gacszawd5wziik73@pengutronix.de> (raw)
In-Reply-To: <20190110045739.19399-6-andrew.smirnov@gmail.com>

Hi Andrey,

On Wed, Jan 09, 2019 at 08:57:23PM -0800, Andrey Smirnov wrote:
> Simplify postscan_setup_bridge() by folding limit setting code into a
> loop. No functional change intended.
> 
> Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com>
> ---
>  drivers/pci/pci.c | 26 +++++++-------------------
>  1 file changed, 7 insertions(+), 19 deletions(-)
> 
> diff --git a/drivers/pci/pci.c b/drivers/pci/pci.c
> index 02b7f091f7..b5e13e5dbc 100644
> --- a/drivers/pci/pci.c
> +++ b/drivers/pci/pci.c
> @@ -330,28 +330,16 @@ static void prescan_setup_bridge(struct pci_dev *dev)
>  
>  static void postscan_setup_bridge(struct pci_dev *dev)
>  {
> +	int r;
> +
>  	/* limit subordinate to last used bus number */
>  	pci_write_config_byte(dev, PCI_SUBORDINATE_BUS, last[PCI_BUS_RESOURCE_BUSN] - 1);
>  
> -	if (last[PCI_BUS_RESOURCE_MEM]) {
> -		last[PCI_BUS_RESOURCE_MEM] = ALIGN(last[PCI_BUS_RESOURCE_MEM], SZ_1M);
> -		pr_debug("bridge NP limit at %pa\n", &last[PCI_BUS_RESOURCE_MEM]);
> -		pci_set_limit(dev, PCI_BUS_RESOURCE_MEM,
> -			      last[PCI_BUS_RESOURCE_MEM] - 1);
> -	}
> -
> -	if (last[PCI_BUS_RESOURCE_MEM_PREF]) {
> -		last[PCI_BUS_RESOURCE_MEM_PREF] = ALIGN(last[PCI_BUS_RESOURCE_MEM_PREF], SZ_1M);
> -		pr_debug("bridge P limit at %pa\n", &last[PCI_BUS_RESOURCE_MEM_PREF]);
> -		pci_set_limit(dev, PCI_BUS_RESOURCE_MEM_PREF,
> -			      last[PCI_BUS_RESOURCE_MEM_PREF] - 1);
> -	}
> -
> -	if (last[PCI_BUS_RESOURCE_IO]) {
> -		last[PCI_BUS_RESOURCE_IO] = ALIGN(last[PCI_BUS_RESOURCE_IO], SZ_4K);
> -		pr_debug("bridge IO limit at %pa\n", &last[PCI_BUS_RESOURCE_IO]);
> -		pci_set_limit(dev, PCI_BUS_RESOURCE_IO,
> -			      last[PCI_BUS_RESOURCE_IO] - 1);
> +	for (r = PCI_BUS_RESOURCE_IO; r <= PCI_BUS_RESOURCE_MEM_PREF; r++) {
> +		if (last[r]) {
> +			last[r] = ALIGN(last[r], pci_resource_to_alignment(r));
> +			pci_set_limit(dev, r, last[r] - 1);
> +		}

Indeed postscan_setup_bridge() gets simpler, but the code as a whole doesn't
get easier to read. Yes, the commonalities are merged into this loop, but
with the price of having to dispatch the differences in a switch/case
later. This often works but here I don't think this is an improvement.

Sascha

-- 
Pengutronix e.K.                           |                             |
Industrial Linux Solutions                 | http://www.pengutronix.de/  |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |

_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox

  reply	other threads:[~2019-01-10 10:09 UTC|newest]

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-01-10  4:57 [PATCH 00/21] PCI improvements Andrey Smirnov
2019-01-10  4:57 ` [PATCH 01/21] PCI: Switch to using %pa to print memory addresses Andrey Smirnov
2019-01-10  4:57 ` [PATCH 02/21] PCI: Replace last_* variables with an array Andrey Smirnov
2019-01-10  4:57 ` [PATCH 03/21] PCI: Consolidate limit/base settting code Andrey Smirnov
2019-01-10  4:57 ` [PATCH 04/21] PCI: Convert prescan_setup_bridge() to use a loop Andrey Smirnov
2019-01-10  4:57 ` [PATCH 05/21] PCI: Convert postscan_setup_bridge() " Andrey Smirnov
2019-01-10 10:09   ` Sascha Hauer [this message]
2019-01-10 19:16     ` Andrey Smirnov
2019-01-11 10:47       ` Sascha Hauer
2019-01-12  2:34         ` Andrey Smirnov
2019-01-10  4:57 ` [PATCH 06/21] PCI: Replace magic number in setup_device() Andrey Smirnov
2019-01-10  4:57 ` [PATCH 07/21] PCI: Remove superfluous parens " Andrey Smirnov
2019-01-10  4:57 ` [PATCH 08/21] PCI: Simplify resource setup code " Andrey Smirnov
2019-01-10  4:57 ` [PATCH 09/21] PCI: Store and reuse BAR offsets Andrey Smirnov
2019-01-10  4:57 ` [PATCH 10/21] PCI: Conver register_pci_controller() to use a loop Andrey Smirnov
2019-01-10  4:57 ` [PATCH 11/21] PCI: Remove unused variables/code Andrey Smirnov
2019-01-10  4:57 ` [PATCH 12/21] PCI: Make pci_scan_bus static Andrey Smirnov
2019-01-10  4:57 ` [PATCH 13/21] PCI: Drop "slots" from struct pci_bus Andrey Smirnov
2019-01-10  4:57 ` [PATCH 14/21] PCI: Drop "resources" " Andrey Smirnov
2019-01-10  4:57 ` [PATCH 15/21] PCI: Drop "name" " Andrey Smirnov
2019-01-10  4:57 ` [PATCH 16/21] PCI: Drop "ops" " Andrey Smirnov
2019-01-10  4:57 ` [PATCH 17/21] PCI: Drop "rom_address" from struct pci_dev Andrey Smirnov
2019-01-10  4:57 ` [PATCH 18/21] PCI: Simplify alloc_pci_dev() Andrey Smirnov
2019-01-10  4:57 ` [PATCH 19/21] PCI: Assume 1:1 mapping if .res_start callback is NULL Andrey Smirnov
2019-01-10  4:57 ` [PATCH 20/21] PCI: Convert ->res_start() to return resource_size_t Andrey Smirnov
2019-01-10  4:57 ` [PATCH 21/21] PCI: Consify pci_ops in struct pci_controller Andrey Smirnov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190110100920.gacszawd5wziik73@pengutronix.de \
    --to=s.hauer@pengutronix.de \
    --cc=andrew.smirnov@gmail.com \
    --cc=barebox@lists.infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox