mail archive of the barebox mailing list
 help / color / mirror / Atom feed
From: Sam Ravnborg <sam@ravnborg.org>
To: Andrey Smirnov <andrew.smirnov@gmail.com>
Cc: barebox@lists.infradead.org
Subject: Re: [PATCH v2 04/16] PCI: Simplify resource setup code in setup_device()
Date: Sat, 12 Jan 2019 12:00:08 +0100	[thread overview]
Message-ID: <20190112110008.GC14273@ravnborg.org> (raw)
In-Reply-To: <20190112072234.21878-5-andrew.smirnov@gmail.com>

Hi Andrey.

> ---
>  drivers/pci/pci.c | 99 ++++++++++++++++++++---------------------------
>  1 file changed, 42 insertions(+), 57 deletions(-)
> 
> diff --git a/drivers/pci/pci.c b/drivers/pci/pci.c
> index b8089207a4..666b457257 100644
> --- a/drivers/pci/pci.c
> +++ b/drivers/pci/pci.c
> @@ -169,8 +169,11 @@ static void setup_device(struct pci_dev *dev, int max_bar)
>  			      cmd & ~(PCI_COMMAND_IO | PCI_COMMAND_MEMORY));
>  
>  	for (bar = 0; bar < max_bar; bar++) {
> -		resource_size_t last_addr;
> +		resource_size_t *last;
>  		u32 orig, mask, size;
> +		unsigned long flags;
> +		const char *kind;
> +		int r;
A more descriptine name than "r" would maybe improve readability.

> @@ -183,67 +186,49 @@ static void setup_device(struct pci_dev *dev, int max_bar)
>  		if (mask & PCI_BASE_ADDRESS_SPACE_IO) { /* IO */
> -			last_io = ALIGN(last_io, size);
> -			last_addr = last_io;
>  		} else if ((mask & PCI_BASE_ADDRESS_MEM_PREFETCH) &&
>  		           last_mem_pref) /* prefetchable MEM */ {
> -			last_mem_pref = ALIGN(last_mem_pref, size);
> -			                           IORESOURCE_PREFETCH;
> -			last_addr = last_mem_pref;
>  		} else { /* non-prefetch MEM */
> -			last_mem = ALIGN(last_mem, size);
> -			last_addr = last_mem;
>  		}
>  
> -		dev->resource[bar].end = last_addr + size - 1;
> +		dev->resource[bar].start = *last;
> +		dev->resource[bar].end = dev->resource[bar].start + size - 1;
> +
> +		pr_debug("pbar%d: allocated at %pa\n", bar, last);
> +
> +		*last += size;

I could not see that dev->resource[bar].end was assigned the
same value with the new code.
Maybe I just missed it because I did not follow *last?

I think it is worth to double check it.

	Sam

_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox

  reply	other threads:[~2019-01-12 11:00 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-01-12  7:22 [PATCH v2 00/16] PCI improvements Andrey Smirnov
2019-01-12  7:22 ` [PATCH v2 01/16] PCI: Switch to using %pa to print memory addresses Andrey Smirnov
2019-01-12  7:22 ` [PATCH v2 02/16] PCI: Replace magic number in setup_device() Andrey Smirnov
2019-01-12  7:22 ` [PATCH v2 03/16] PCI: Remove superfluous parens " Andrey Smirnov
2019-01-12  7:22 ` [PATCH v2 04/16] PCI: Simplify resource setup code " Andrey Smirnov
2019-01-12 11:00   ` Sam Ravnborg [this message]
2019-01-12 20:49     ` Andrey Smirnov
2019-01-12 21:35       ` Sam Ravnborg
2019-01-12 11:01   ` Sam Ravnborg
2019-01-12  7:22 ` [PATCH v2 05/16] PCI: Store and reuse BAR offsets Andrey Smirnov
2019-01-12  7:22 ` [PATCH v2 06/16] PCI: Remove unused variables/code Andrey Smirnov
2019-01-12  7:22 ` [PATCH v2 07/16] PCI: Make pci_scan_bus static Andrey Smirnov
2019-01-12 11:04   ` Sam Ravnborg
2019-01-12 19:52     ` Andrey Smirnov
2019-01-12  7:22 ` [PATCH v2 08/16] PCI: Drop "slots" from struct pci_bus Andrey Smirnov
2019-01-12  7:22 ` [PATCH v2 09/16] PCI: Drop "resources" " Andrey Smirnov
2019-01-12  7:22 ` [PATCH v2 10/16] PCI: Drop "name" " Andrey Smirnov
2019-01-12  7:22 ` [PATCH v2 11/16] PCI: Drop "ops" " Andrey Smirnov
2019-01-12  7:22 ` [PATCH v2 12/16] PCI: Drop "rom_address" from struct pci_dev Andrey Smirnov
2019-01-12  7:22 ` [PATCH v2 13/16] PCI: Simplify alloc_pci_dev() Andrey Smirnov
2019-01-12  7:22 ` [PATCH v2 14/16] PCI: Assume 1:1 mapping if .res_start callback is NULL Andrey Smirnov
2019-01-12  7:22 ` [PATCH v2 15/16] PCI: Convert ->res_start() to return resource_size_t Andrey Smirnov
2019-01-12  7:22 ` [PATCH v2 16/16] PCI: Consify pci_ops in struct pci_controller Andrey Smirnov
2019-01-12 11:07 ` [PATCH v2 00/16] PCI improvements Sam Ravnborg

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190112110008.GC14273@ravnborg.org \
    --to=sam@ravnborg.org \
    --cc=andrew.smirnov@gmail.com \
    --cc=barebox@lists.infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox