From: Ahmad Fatoum <a.fatoum@pengutronix.de>
To: barebox@lists.infradead.org
Cc: ore@pengutronix.de, Ahmad Fatoum <a.fatoum@pengutronix.de>
Subject: [PATCH 2/9] gpiolib: implement gpio_direction_input/output
Date: Mon, 16 Jan 2023 14:44:54 +0100 [thread overview]
Message-ID: <20230116134501.2006391-3-a.fatoum@pengutronix.de> (raw)
In-Reply-To: <20230116134501.2006391-1-a.fatoum@pengutronix.de>
These are straight wrappers around existing functions, but with a name
that's more like their Linux counterparts.
Signed-off-by: Ahmad Fatoum <a.fatoum@pengutronix.de>
---
include/gpiod.h | 12 +++++++++++-
1 file changed, 11 insertions(+), 1 deletion(-)
diff --git a/include/gpiod.h b/include/gpiod.h
index 8abf86db8682..df02b86e1ee8 100644
--- a/include/gpiod.h
+++ b/include/gpiod.h
@@ -57,12 +57,22 @@ static inline int gpiod_get(struct device *dev,
return dev_gpiod_get(dev, dev->of_node, _con_id, flags, NULL);
}
-static inline void gpiod_set_value(int gpio, bool value)
+static inline void gpiod_direction_input(int gpio)
+{
+ gpio_direction_input(gpio);
+}
+
+static inline void gpiod_direction_output(int gpio, bool value)
{
if (gpio != -ENOENT)
gpio_direction_active(gpio, value);
}
+static inline void gpiod_set_value(int gpio, bool value)
+{
+ gpiod_direction_output(gpio, value);
+}
+
static inline int gpiod_get_value(int gpio)
{
if (gpio < 0)
--
2.30.2
next prev parent reply other threads:[~2023-01-16 13:47 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-01-16 13:44 [PATCH 0/9] net: dsa: add Realtek (rtl8365mb/rtl8366rb) switch support Ahmad Fatoum
2023-01-16 13:44 ` [PATCH 1/9] driver: alias of_match_ptr and DRV_OF_COMPAT Ahmad Fatoum
2023-01-16 13:44 ` Ahmad Fatoum [this message]
2023-01-16 13:44 ` [PATCH 3/9] net: dsa: rename dsa_ops to dsa_switch_ops Ahmad Fatoum
2023-01-16 13:44 ` [PATCH 4/9] net: dsa: factor out dsa_port_alloc helper Ahmad Fatoum
2023-01-16 13:44 ` [PATCH 5/9] net: dsa: populate struct dsa_port::index/dev members Ahmad Fatoum
2023-01-16 13:44 ` [PATCH 6/9] net: dsa: always call port_pre_enable before port_enable Ahmad Fatoum
2023-01-16 13:44 ` [PATCH 7/9] net: dsa: add some helpers to ease porting kernel drivers Ahmad Fatoum
2023-01-16 13:45 ` [PATCH 8/9] net: dsa: add struct dsa_switch::priv member for driver use Ahmad Fatoum
2023-01-16 13:45 ` [PATCH 9/9] net: dsa: add Realtek (rtl8365mb/rtl8366rb) switch support Ahmad Fatoum
2023-01-23 8:21 ` [PATCH 0/9] " Sascha Hauer
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20230116134501.2006391-3-a.fatoum@pengutronix.de \
--to=a.fatoum@pengutronix.de \
--cc=barebox@lists.infradead.org \
--cc=ore@pengutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox