mail archive of the barebox mailing list
 help / color / mirror / Atom feed
* [PATCH 1/6] arch: move promptless options to end of Kconfig file
@ 2025-03-13  6:45 Ahmad Fatoum
  2025-03-13  6:45 ` [PATCH 2/6] RISC-V: rename HAS_CACHE to RISCV_ICACHE Ahmad Fatoum
                   ` (4 more replies)
  0 siblings, 5 replies; 6+ messages in thread
From: Ahmad Fatoum @ 2025-03-13  6:45 UTC (permalink / raw)
  To: barebox; +Cc: Ahmad Fatoum

Later commits will move many more promptless arch symbols into the file,
so prepare for that by moving the current ones to the end and leave the
options, which either have a prompt or are not boolean at the start.

Signed-off-by: Ahmad Fatoum <a.fatoum@pengutronix.de>
---
 arch/Kconfig | 32 ++++++++++++++++----------------
 1 file changed, 16 insertions(+), 16 deletions(-)

diff --git a/arch/Kconfig b/arch/Kconfig
index aee5375dc70c..21175b90a076 100644
--- a/arch/Kconfig
+++ b/arch/Kconfig
@@ -9,19 +9,6 @@
 #
 source "arch/$(SRCARCH)/Kconfig"
 
-config ARCH_HAS_CTRLC
-	bool
-
-#
-# Select this option if the architecture assumes DMA devices are coherent
-# by default.
-#
-config ARCH_DMA_DEFAULT_COHERENT
-	bool
-
-config ARCH_HAS_ASAN_FIBER_API
-	bool
-
 config ARCH_LINUX_NAME
 	string
 	default "$(SRCARCH)"
@@ -30,9 +17,6 @@ config ARCH_MKIMAGE_NAME
 	string
 	default "invalid"
 
-config HAVE_ARCH_BOARD_GENERIC_DT
-	bool
-
 menu "General architecture-dependent options"
 
 config BOARD_GENERIC_DT
@@ -64,3 +48,19 @@ config BOARD_GENERIC_FIT
 	  installed on the build host.
 
 endmenu
+
+config ARCH_HAS_CTRLC
+	bool
+
+#
+# Select this option if the architecture assumes DMA devices are coherent
+# by default.
+#
+config ARCH_DMA_DEFAULT_COHERENT
+	bool
+
+config ARCH_HAS_ASAN_FIBER_API
+	bool
+
+config HAVE_ARCH_BOARD_GENERIC_DT
+	bool
-- 
2.39.5




^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2025-03-13  6:46 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-03-13  6:45 [PATCH 1/6] arch: move promptless options to end of Kconfig file Ahmad Fatoum
2025-03-13  6:45 ` [PATCH 2/6] RISC-V: rename HAS_CACHE to RISCV_ICACHE Ahmad Fatoum
2025-03-13  6:45 ` [PATCH 3/6] treewide: retire CONFIG_HAS_CACHE Ahmad Fatoum
2025-03-13  6:45 ` [PATCH 4/6] arch: move hidden arch options to arch/Kconfig Ahmad Fatoum
2025-03-13  6:45 ` [PATCH 5/6] arch: move PHYS_ADDR_T_64BIT definition " Ahmad Fatoum
2025-03-13  6:45 ` [PATCH 6/6] x86: make phys_addr_t 64-bit on x86_64 Ahmad Fatoum

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox