From: Ahmad Fatoum <a.fatoum@pengutronix.de>
To: Marco Felsch <m.felsch@pengutronix.de>, barebox@lists.infradead.org
Cc: Jules Maselbas <jmaselbas@kalray.eu>
Subject: Re: [PATCH 06/10] gpiolib: refactor gpio-line-names parsing
Date: Tue, 13 Jun 2023 09:44:47 +0200 [thread overview]
Message-ID: <215e513a-1919-f201-265d-f942e755a7a6@pengutronix.de> (raw)
In-Reply-To: <20230602074921.2687669-7-m.felsch@pengutronix.de>
On 02.06.23 09:49, Marco Felsch wrote:
> Move the gpio-line-names parsing out of of_gpiochip_scan_hogs() since
> this has nothing to do with gpio-hogs. The new function is very similar
> with the kernel function devprop_gpiochip_set_names().
>
> Signed-off-by: Marco Felsch <m.felsch@pengutronix.de>
Reviewed-by: Ahmad Fatoum <a.fatoum@pengutronix.de>
> ---
> drivers/gpio/gpiolib.c | 104 ++++++++++++++++++++++++++---------------
> 1 file changed, 66 insertions(+), 38 deletions(-)
>
> diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
> index 166356c85a..127cc60abd 100644
> --- a/drivers/gpio/gpiolib.c
> +++ b/drivers/gpio/gpiolib.c
> @@ -515,48 +515,11 @@ static int of_hog_gpio(struct device_node *np, struct gpio_chip *chip,
> static int of_gpiochip_scan_hogs(struct gpio_chip *chip)
> {
> struct device_node *np;
> - int ret, i, count;
> + int ret, i;
>
> if (!IS_ENABLED(CONFIG_OFDEVICE) || !chip->dev->of_node)
> return 0;
>
> - count = of_property_count_strings(chip->dev->of_node,
> - "gpio-line-names");
> -
> - if (count > 0) {
> - const char **names = xzalloc(count * sizeof(char *));
> -
> - ret = of_property_read_string_array(chip->dev->of_node,
> - "gpio-line-names", names,
> - count);
> - if (ret < 0) {
> - dev_warn(chip->dev, "failed to read GPIO line names\n");
> - kfree(names);
> - return ret;
> - }
> -
> - /*
> - * Since property 'gpio-line-names' cannot contains gaps, we
> - * have to be sure we only assign those pins that really exists
> - * since chip->ngpio can be less.
> - */
> - if (count > chip->ngpio)
> - count = chip->ngpio;
> -
> - for (i = 0; i < count; i++) {
> - /*
> - * Allow overriding "fixed" names provided by the GPIO
> - * provider. The "fixed" names are more often than not
> - * generic and less informative than the names given in
> - * device properties.
> - */
> - if (names[i] && names[i][0])
> - gpio_desc[chip->base + i].name = names[i];
> - }
> -
> - free(names);
> - }
> -
> for_each_available_child_of_node(chip->dev->of_node, np) {
> if (!of_property_read_bool(np, "gpio-hog"))
> continue;
> @@ -576,6 +539,66 @@ static int of_gpiochip_scan_hogs(struct gpio_chip *chip)
> return 0;
> }
>
> +/*
> + * of_gpiochip_set_names - Set GPIO line names using OF properties
> + * @chip: GPIO chip whose lines should be named, if possible
> + *
> + * Looks for device property "gpio-line-names" and if it exists assigns
> + * GPIO line names for the chip. The memory allocated for the assigned
> + * names belong to the underlying firmware node and should not be released
> + * by the caller.
> + */
> +static int of_gpiochip_set_names(struct gpio_chip *chip)
> +{
> + struct device *dev = chip->dev;
> + struct device_node *np;
> + const char **names;
> + int ret, i, count;
> +
> + np = dev_of_node(dev);
> + if (!np)
> + return 0;
> +
> + count = of_property_count_strings(np, "gpio-line-names");
> + if (count < 0)
> + return 0;
> +
> + names = kcalloc(count, sizeof(*names), GFP_KERNEL);
> + if (!names)
> + return -ENOMEM;
> +
> + ret = of_property_read_string_array(np, "gpio-line-names",
> + names, count);
> + if (ret < 0) {
> + dev_warn(dev, "failed to read GPIO line names\n");
> + kfree(names);
> + return ret;
> + }
> +
> + /*
> + * Since property 'gpio-line-names' cannot contains gaps, we
> + * have to be sure we only assign those pins that really exists
> + * since chip->ngpio can be less.
> + */
> + if (count > chip->ngpio)
> + count = chip->ngpio;
> +
> + for (i = 0; i < count; i++) {
> + /*
> + * Allow overriding "fixed" names provided by the GPIO
> + * provider. The "fixed" names are more often than not
> + * generic and less informative than the names given in
> + * device properties.
> + */
> + if (names[i] && names[i][0])
> + gpio_desc[chip->base + i].name = names[i];
> + }
> +
> + free(names);
> +
> + return 0;
> +}
> +
> #ifdef CONFIG_OFDEVICE
> static const char *gpio_suffixes[] = {
> "gpios",
> @@ -637,6 +660,7 @@ int dev_gpiod_get_index(struct device *dev,
>
> int gpiochip_add(struct gpio_chip *chip)
> {
> + int ret;
> int i;
>
> if (chip->base >= 0) {
> @@ -656,6 +680,10 @@ int gpiochip_add(struct gpio_chip *chip)
> for (i = chip->base; i < chip->base + chip->ngpio; i++)
> gpio_desc[i].chip = chip;
>
> + ret = of_gpiochip_set_names(chip);
> + if (ret)
> + return ret;
> +
> return of_gpiochip_scan_hogs(chip);
> }
>
--
Pengutronix e.K. | |
Steuerwalder Str. 21 | http://www.pengutronix.de/ |
31137 Hildesheim, Germany | Phone: +49-5121-206917-0 |
Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |
next prev parent reply other threads:[~2023-06-13 7:45 UTC|newest]
Thread overview: 27+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-06-02 7:49 [PATCH 00/10] Fix gpio-hogs and sync with Linux gpiolib Marco Felsch
2023-06-02 7:49 ` [PATCH 01/10] gpiolib: fix gpio-hog functionality Marco Felsch
2023-06-13 7:36 ` Ahmad Fatoum
2023-06-02 7:49 ` [PATCH 02/10] gpiolib: simplify for loop break condition Marco Felsch
2023-06-13 7:37 ` Ahmad Fatoum
2023-06-02 7:49 ` [PATCH 03/10] gpiolib: rename local gpio-line-names variable Marco Felsch
2023-06-13 7:38 ` Ahmad Fatoum
2023-06-02 7:49 ` [PATCH 04/10] gpiolib: fix gpio name memory leak Marco Felsch
2023-06-13 7:39 ` Ahmad Fatoum
2023-06-02 7:49 ` [PATCH 05/10] gpiolib: fix missing error check while query gpio-line-names Marco Felsch
2023-06-13 7:43 ` Ahmad Fatoum
2023-06-02 7:49 ` [PATCH 06/10] gpiolib: refactor gpio-line-names parsing Marco Felsch
2023-06-13 7:44 ` Ahmad Fatoum [this message]
2023-06-02 7:49 ` [PATCH 07/10] gpiolib: introduce of_gpiochip_add to bundle all of functions Marco Felsch
2023-06-13 7:46 ` Ahmad Fatoum
2023-06-02 7:49 ` [PATCH 08/10] OF: gpio: snyc of_get_named_gpio_flags variable with kernel Marco Felsch
2023-06-02 8:04 ` Jules Maselbas
2023-06-13 7:46 ` Ahmad Fatoum
2023-06-02 7:49 ` [PATCH 09/10] OF: gpio: fix device_node leakage Marco Felsch
2023-06-13 7:49 ` Ahmad Fatoum
2023-06-13 8:22 ` Marco Felsch
2023-06-02 7:49 ` [PATCH 10/10] gpiolib: add of_xlate support Marco Felsch
2023-06-02 8:11 ` Jules Maselbas
2023-06-05 7:49 ` Jules Maselbas
2023-06-05 9:51 ` Marco Felsch
2023-06-13 7:58 ` Ahmad Fatoum
2023-06-13 13:05 ` Ahmad Fatoum
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=215e513a-1919-f201-265d-f942e755a7a6@pengutronix.de \
--to=a.fatoum@pengutronix.de \
--cc=barebox@lists.infradead.org \
--cc=jmaselbas@kalray.eu \
--cc=m.felsch@pengutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox