From: Ahmad Fatoum <a.fatoum@pengutronix.de>
To: Sascha Hauer <s.hauer@pengutronix.de>,
Barebox List <barebox@lists.infradead.org>
Subject: Re: [PATCH v2 17/19] crypto: add ECDSA support
Date: Mon, 5 Aug 2024 13:57:36 +0200 [thread overview]
Message-ID: <3fe60919-c7f4-40cf-8bb5-d4b1d375e116@pengutronix.de> (raw)
In-Reply-To: <20240801055737.3190132-18-s.hauer@pengutronix.de>
On 01.08.24 07:57, Sascha Hauer wrote:
> This adds ECDSA signature verification support. The code is based on the
> Linux code as of Linux-6.10. The Linux code expects the key to be in
> ASN.1 encoded format. We don't need this in barebox as directly compile
> the x and y key values into the binary, so this is left out.
>
> Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
> ---
> crypto/Kconfig | 20 ++++
> crypto/Makefile | 19 ++++
> crypto/ecdsa.c | 169 ++++++++++++++++++++++++++++++
> include/asm-generic/barebox.lds.h | 7 ++
> include/ecdsa.h | 21 ++++
> 5 files changed, 236 insertions(+)
> create mode 100644 crypto/ecdsa.c
> create mode 100644 include/ecdsa.h
>
> diff --git a/crypto/Kconfig b/crypto/Kconfig
> index e953ef5e15..eeacd9ffb7 100644
> --- a/crypto/Kconfig
> +++ b/crypto/Kconfig
> @@ -156,4 +156,24 @@ config JWT
> config CRYPTO_ECC
> bool
>
> +config CRYPTO_ECDSA
> + bool "ECDSA support"
> + select CRYPTO_ECC
> +
> +config CRYPTO_ECDSA_BUILTIN_KEYS
> + bool
> + default y if CRYPTO_ECDSA_KEY != ""
> + select KEYTOC
> +
> +config CRYPTO_ECDSA_KEY
> + depends on CRYPTO_ECDSA
> + string "ECDSA key to compile in"
> + help
> + This option should be a filename of a PEM-formatted file containing
> + X.509 certificates to be included into barebox. If the string starts
> + with "pkcs11:" it is interpreted as a PKCS#11 URI rather than a file.
> +
> + This avoids the mkimage dependency of CONFIG_BOOTM_FITIMAGE_PUBKEY
> + at the cost of an openssl build-time dependency.
Why can't this option take multiple space-separated paths?
> +static struct ecdsa_public_key *ecdsa_key_dup(const struct ecdsa_public_key *key)
> +{
> + struct ecdsa_public_key *new;
> + int key_size_bits;
> +
> + key_size_bits = ecdsa_key_size(key->curve_name);
> + if (!key_size_bits)
> + return NULL;
> +
> + new = xmemdup(key, sizeof(*key));
> + new->x = xmemdup(key->x, key_size_bits / 8);
> + new->y = xmemdup(key->y, key_size_bits / 8);
> + new->size_bits = key_size_bits;
I think you'll want to explicitly initialize the linked list member here
instead of leaving it dangling.
> +
> + return new;
> +}
> +
> +extern const struct ecdsa_public_key * const __ecdsa_keys_start;
> +extern const struct ecdsa_public_key * const __ecdsa_keys_end;
This looks odd. Shouldn't this be array of unknown size [].
> +
> +static int ecdsa_init_keys(void)
> +{
> + const struct ecdsa_public_key * const *iter;
and this would be a single level pointer?
> + struct ecdsa_public_key *key;
> + int ret;
> +
> + for (iter = &__ecdsa_keys_start; iter != &__ecdsa_keys_end; iter++) {
> + key = ecdsa_key_dup(*iter);
> + if (!key) {
> + pr_err("Ignoring key with unknown curve_name %s\n", key->curve_name);
> + continue;
> + }
> +
> + ret = ecdsa_key_add(key);
> + if (ret)
> + pr_err("Cannot add rsa key: %pe\n", ERR_PTR(ret));
> + }
> +
> + return 0;
> +}
ntifier: GPL-2.0-only
> +#ifndef _ECDSA_H
> +#define _ECDSA_H
> +
> +struct ecdsa_public_key {
> + const char *curve_name; /* Name of curve, e.g. "prime256v1" */
> + const void *x; /* x coordinate of public key */
> + const void *y; /* y coordinate of public key */
Why void and not a specific type?
Cheers,
Ahmad
--
Pengutronix e.K. | |
Steuerwalder Str. 21 | http://www.pengutronix.de/ |
31137 Hildesheim, Germany | Phone: +49-5121-206917-0 |
Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |
next prev parent reply other threads:[~2024-08-05 11:58 UTC|newest]
Thread overview: 45+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-08-01 5:57 [PATCH v2 00/19] Add ECDSA support for FIT image verification Sascha Hauer
2024-08-01 5:57 ` [PATCH v2 01/19] errno: include string for EOPNOTSUPP Sascha Hauer
2024-08-05 9:28 ` Ahmad Fatoum
2024-08-01 5:57 ` [PATCH v2 02/19] rsatoc: disable deprecated function warnings Sascha Hauer
2024-08-05 9:29 ` Ahmad Fatoum
2024-08-01 5:57 ` [PATCH v2 03/19] rsatoc: remove unnecessary function call Sascha Hauer
2024-08-05 9:29 ` Ahmad Fatoum
2024-08-01 5:57 ` [PATCH v2 04/19] rsatoc: pass EVP_PKEY around Sascha Hauer
2024-08-05 9:35 ` Ahmad Fatoum
2024-08-01 5:57 ` [PATCH v2 05/19] rsatoc: rename rsa_err() to openssl_error() Sascha Hauer
2024-08-05 9:37 ` Ahmad Fatoum
2024-08-01 5:57 ` [PATCH v2 06/19] rsatoc: move engine initialization to engine_get_pub_key() Sascha Hauer
2024-08-05 9:47 ` Ahmad Fatoum
2024-08-01 5:57 ` [PATCH v2 07/19] rsatoc: cleanup error handling Sascha Hauer
2024-08-05 9:54 ` Ahmad Fatoum
2024-08-05 10:07 ` Sascha Hauer
2024-08-01 5:57 ` [PATCH v2 08/19] rsatoc: remove unnecessary error check Sascha Hauer
2024-08-05 9:56 ` Ahmad Fatoum
2024-08-01 5:57 ` [PATCH v2 09/19] rsatoc: use non deprecated openssl functions to retrieve RSA params Sascha Hauer
2024-08-05 10:02 ` Ahmad Fatoum
2024-08-05 10:29 ` Ahmad Fatoum
2024-08-01 5:57 ` [PATCH v2 10/19] rsatoc: check error value of gen_key() Sascha Hauer
2024-08-05 10:03 ` Ahmad Fatoum
2024-08-01 5:57 ` [PATCH v2 11/19] rsatoc: rename to keytoc Sascha Hauer
2024-08-05 10:05 ` Ahmad Fatoum
2024-08-01 5:57 ` [PATCH v2 12/19] keytoc: add ecdsa support Sascha Hauer
2024-08-05 11:04 ` Ahmad Fatoum
2024-08-01 5:57 ` [PATCH v2 13/19] keytoc: Let openssl_error() take a format string Sascha Hauer
2024-08-05 10:22 ` Ahmad Fatoum
2024-08-01 5:57 ` [PATCH v2 14/19] keytoc: clarify error messages Sascha Hauer
2024-08-05 10:06 ` Ahmad Fatoum
2024-08-01 5:57 ` [PATCH v2 15/19] malloc: implement free_sensitive() Sascha Hauer
2024-08-05 10:17 ` Ahmad Fatoum
2024-08-01 5:57 ` [PATCH v2 16/19] Add elliptic curve cryptography (ECC) helper functions Sascha Hauer
2024-08-05 11:32 ` Ahmad Fatoum
2024-08-01 5:57 ` [PATCH v2 17/19] crypto: add ECDSA support Sascha Hauer
2024-08-05 11:57 ` Ahmad Fatoum [this message]
2024-08-05 12:44 ` Sascha Hauer
2024-08-06 9:13 ` Ahmad Fatoum
2024-08-01 5:57 ` [PATCH v2 18/19] crypto: make RSA a visible option Sascha Hauer
2024-08-05 10:19 ` Ahmad Fatoum
2024-08-01 5:57 ` [PATCH v2 19/19] fit: Add ecdsa support Sascha Hauer
2024-08-05 12:04 ` Ahmad Fatoum
2024-08-06 6:03 ` [PATCH v2 00/19] Add ECDSA support for FIT image verification Sascha Hauer
2024-08-06 6:07 ` Sascha Hauer
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=3fe60919-c7f4-40cf-8bb5-d4b1d375e116@pengutronix.de \
--to=a.fatoum@pengutronix.de \
--cc=barebox@lists.infradead.org \
--cc=s.hauer@pengutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox