From: Ahmad Fatoum <a.fatoum@pengutronix.de>
To: Sascha Hauer <s.hauer@pengutronix.de>
Cc: barebox@lists.infradead.org
Subject: Re: [PATCH 09/12] commands: reginfo: make command mpc5xxx-specific
Date: Tue, 15 Oct 2024 09:20:39 +0200 [thread overview]
Message-ID: <6173e87c-7deb-481d-a543-8665b691b8c2@pengutronix.de> (raw)
In-Reply-To: <Zw4WMLWERHQHcqLK@pengutronix.de>
Hello Sascha,
On 15.10.24 09:13, Sascha Hauer wrote:
> On Mon, Oct 14, 2024 at 01:50:37PM +0200, Ahmad Fatoum wrote:
>> -void reginfo(void)
>> +static void reginfo(void)
>> {
>> puts ("\nMPC5200 registers\n");
>> printf ("MBAR=%08x\n", CFG_MBAR);
>> @@ -61,3 +62,4 @@ void reginfo(void)
>> printf ("\tSDRAMCS1: %08X\n",
>> in_be32((void*)MPC5XXX_SDRAM_CS1CFG));
>> }
>> +DEFINE_SIMPLE_COMMAND(reginfo);
>
> This is great for development, but not so nice for a broader use in the
> tree.
It's meant for one-off things during development and we should at least
have one instance in tree to verify that it still works.
This would be that instance :-)
>
>> -BAREBOX_CMD_START(reginfo)
>> - .cmd = do_reginfo,
>> - BAREBOX_CMD_DESC("print register information")
>
> We are losing the command description and get a "call func reginfo"
> instead which is not really an improvement.
That's how it currently looks like:
https://www.barebox.org/doc/latest/commands/info/reginfo.html
And it's confusing, because it's only implemented for one specific
PowerPC machine. I like the new help text more in this instance.
Cheers,
Ahmad
>
> Sascha
>
--
Pengutronix e.K. | |
Steuerwalder Str. 21 | http://www.pengutronix.de/ |
31137 Hildesheim, Germany | Phone: +49-5121-206917-0 |
Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |
next prev parent reply other threads:[~2024-10-15 7:21 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-10-14 11:50 [PATCH 00/12] include: common.h: make it include only headers Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 01/12] include: common.h: move barebox startup functions into separate header Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 02/12] include: common.h: move ctrlc() functions into stdio.h Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 03/12] include: common.h: move out integer string parsing functions Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 04/12] include: common.h: move out endianness macro sanity check Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 05/12] include: common.h: move out user interface functions into stdio.h Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 06/12] include: common.h: move out memory option parsing prototypes Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 07/12] include: common.h: move out RW_BUF_SIZE definition Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 08/12] commands: add macro to simplify defining one shot commands Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 09/12] commands: reginfo: make command mpc5xxx-specific Ahmad Fatoum
2024-10-15 7:13 ` Sascha Hauer
2024-10-15 7:20 ` Ahmad Fatoum [this message]
2024-10-14 11:50 ` [PATCH 10/12] include: common.h: move out get_ram_size Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 11/12] include: align: reword STACK_ALIGN_ARRAY macro parameter for clarity Ahmad Fatoum
2024-10-14 11:50 ` [PATCH 12/12] ARM: bcm283x: remove common.h include in mbox.h Ahmad Fatoum
2024-10-15 7:10 ` [PATCH 00/12] include: common.h: make it include only headers Sascha Hauer
2024-10-15 7:16 ` Sascha Hauer
2024-10-15 13:35 ` Konstantin Ryabitsev
2024-10-16 10:25 ` Sascha Hauer
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=6173e87c-7deb-481d-a543-8665b691b8c2@pengutronix.de \
--to=a.fatoum@pengutronix.de \
--cc=barebox@lists.infradead.org \
--cc=s.hauer@pengutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox