From: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
To: Sascha Hauer <s.hauer@pengutronix.de>
Cc: barebox@lists.infradead.org
Subject: Re: [PATCH 3/8] console: factorise function to get the console by name
Date: Fri, 27 Sep 2013 17:07:35 +0800 [thread overview]
Message-ID: <662887B7-20C6-4FBF-AFB5-2F83B221F64D@jcrosoft.com> (raw)
In-Reply-To: <20130927090556.GS30088@pengutronix.de>
On Sep 27, 2013, at 5:05 PM, Sascha Hauer <s.hauer@pengutronix.de> wrote:
> On Fri, Sep 27, 2013 at 10:58:47AM +0200, Jean-Christophe PLAGNIOL-VILLARD wrote:
>> On 10:50 Fri 27 Sep , Sascha Hauer wrote:
>>> On Fri, Sep 27, 2013 at 09:14:13AM +0200, Jean-Christophe PLAGNIOL-VILLARD wrote:
>>>> rename it to console_get_by_name
>>>>
>>>> +struct console_device *console_get_by_name(const char *cname)
>>>> +{
>>>> + struct console_device *cdev;
>>>> + const char *target;
>>>> +
>>>> + for_each_console(cdev) {
>>>> + target = dev_id(&cdev->class_dev);
>>>> + if (strcmp(cname, target))
>>>> + continue;
>>>> + if ((cdev->f_active & (CONSOLE_STDIN | CONSOLE_STDOUT))
>>>> + return cdev;
>>>> + return NULL;
>>>> + }
>>>> + return NULL;
>>>> +}
>>>> +EXPORT_SYMBOL(console_get_by_name);
>>>
>>> I know this patch doesn't change the current behaviour, but a common
>>> function console_get_by_name() should return return the console by name
>>> regardless of whether it's active or not.
>>
>> I change it behaviour later as now this function will check the console
>> feature
>>
>> as the current implemetation do it too but in the wrong way
>>>
>>> For the loadx code this would be a net win aswell. I think this code
>>> should not depend on an active console but the other way round: It
>>> should clear the CONSOLE_STDIN/CONSOLE_STDOUT during loadx operation.
>>> This way we could easily make sure there are no printf message garbling
>>> the line during transfers and still we could have console messages on
>>> other consoles.
>>
>> patch 8 finaly clean it
>
> ?
>
> patch 8/8 is an atmel serial driver specific patch that changes nothing
> in this regard.
>
it's patch 9 I forget to send this one
but put it on the git
> What I mean is that the loadx stuff should do a cdev->active = 0 so that
> during transfers printf is still possible without corrupting the
> transfers. This behaviour is not changed in this series.
yeah I agree
Best Regards,
J.
>
>
> Sascha
>
> --
> Pengutronix e.K. | |
> Industrial Linux Solutions | http://www.pengutronix.de/ |
> Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0 |
> Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |
_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox
next prev parent reply other threads:[~2013-09-27 9:08 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-09-27 7:12 [PATCH 0/8] more serial cleanup Jean-Christophe PLAGNIOL-VILLARD
2013-09-27 7:14 ` [PATCH 1/8] console_simple: fix: set f_active Jean-Christophe PLAGNIOL-VILLARD
2013-09-27 7:14 ` [PATCH 2/8] console: factorise function to get the first enabled console Jean-Christophe PLAGNIOL-VILLARD
2013-09-27 8:44 ` Sascha Hauer
2013-09-27 7:14 ` [PATCH 3/8] console: factorise function to get the console by name Jean-Christophe PLAGNIOL-VILLARD
2013-09-27 8:50 ` Sascha Hauer
2013-09-27 8:58 ` Jean-Christophe PLAGNIOL-VILLARD
2013-09-27 9:05 ` Sascha Hauer
2013-09-27 9:07 ` Jean-Christophe PLAGNIOL-VILLARD [this message]
2013-09-27 7:14 ` [PATCH 4/8] console: introduce startup and shutdown Jean-Christophe PLAGNIOL-VILLARD
2013-09-27 8:55 ` Sascha Hauer
2013-09-27 9:03 ` Jean-Christophe PLAGNIOL-VILLARD
2013-09-27 9:09 ` Sascha Hauer
2013-09-27 9:20 ` Jean-Christophe PLAGNIOL-VILLARD
2013-09-27 7:14 ` [PATCH 5/8] loadbxy: use console_open/close Jean-Christophe PLAGNIOL-VILLARD
2013-09-27 7:14 ` [PATCH 6/8] animeo_ip: update to use console_open/close for rs485 crossed detection Jean-Christophe PLAGNIOL-VILLARD
2013-09-27 7:14 ` [PATCH 7/8] serial: amba-pl011: add start and shutdown support Jean-Christophe PLAGNIOL-VILLARD
2013-09-27 7:14 ` [PATCH 8/8] serial: atmel: " Jean-Christophe PLAGNIOL-VILLARD
2013-09-27 9:07 ` [PATCH 9/9] console: console_get_by_name pass flags Jean-Christophe PLAGNIOL-VILLARD
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=662887B7-20C6-4FBF-AFB5-2F83B221F64D@jcrosoft.com \
--to=plagnioj@jcrosoft.com \
--cc=barebox@lists.infradead.org \
--cc=s.hauer@pengutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox