mail archive of the barebox mailing list
 help / color / mirror / Atom feed
From: Andrey Smirnov <andrew.smirnov@gmail.com>
To: Sascha Hauer <s.hauer@pengutronix.de>
Cc: Barebox List <barebox@lists.infradead.org>
Subject: Re: [PATCH v2 00/65] PCI i.MX6/DesignWare sync up with 4.20-rc1
Date: Mon, 7 Jan 2019 14:55:56 -0800	[thread overview]
Message-ID: <CAHQ1cqE4Yw42KROoddZ_1OabhwN7jrutbA_u3LDGkgJrz1X=DA@mail.gmail.com> (raw)
In-Reply-To: <20181217051925.17582-1-andrew.smirnov@gmail.com>

On Sun, Dec 16, 2018 at 9:19 PM Andrey Smirnov <andrew.smirnov@gmail.com> wrote:
>
> Everyone:
>
> As a part of working on adding support for PCI on i.MX7D/8MQ, I spent
> some time looking through Linux commit history of pci-imx6.c and
> pcie-designware*.c and porting various patches to minimize the
> differences between the two codebases. This series is the result of
> that effort. All of the patches are either fixes for missed corner
> cases or code simplifications/improvements, so no functonal changes
> are expected.
>
> Tested on ZII RDU2 i.MX6Q board with i210 Ethernet card by booting
> 4.20-rc1 via TFTP (via PCI/i210). Also tested as a part of adding on
> i.MX7D/i.MX8MQ suport on i.MX7D SabreSD and i.MX8MQ RDU3 boards.
>
> Feedback is welcome!
>
> Changes since v1:
>
>   - Fixed incorrect check/bug in "PCI: designware: Keep viewport fixed
>     for IO transaction if num_viewport > 2"
>
>   - Added patches containing code to support iATU unroll in order to
>     support i.MX8MQ
>
> Thanks,
> Andrey Smirnov

Sascha:

Just to make sure, this series is in you review queue and it didn't
get lost, correct?

Thanks,
Andrey Smirnov

>
> Andrey Smirnov (65):
>   PCI: desginware: Remove bogus prototypes
>   PCI: designware: Consolidate outbound iATU programming functions
>   PCI: designware: Use iATU0 for cfg and IO, iATU1 for MEM
>   PCI: designware: Fix PORT_LOGIC_LINK_WIDTH_MASK
>   PCI: designware: Use exact access size in dw_pcie_cfg_read()
>   PCI: designware: Simplify dw_pcie_cfg_read/write() interfaces
>   PCI: designware: Require config accesses to be naturally aligned
>   PCI: designware: Make "num-lanes" an optional DT property
>   PCI: designware: Ensure ATU is enabled before IO/conf space accesses
>   PCI: designware: Simplify control flow
>   PCI: designware: Make config accessor override checking symmetric
>   PCI: designware: Explain why we don't program ATU for some platforms
>   PCI: imx6: Move link up check into imx6_pcie_wait_for_link()
>   PCI: designware: Add generic dw_pcie_wait_for_link()
>   PCI: designware: Add default link up check if sub-driver doesn't
>     override
>   PCI: designware: Move Root Complex setup code to dw_pcie_setup_rc()
>   PCI: designware: Remove incorrect RC memory base/limit configuration
>   PCI: designware: Return data directly from dw_pcie_readl_rc()
>   PCI: designware: Move link wait definitions to .c file
>   PCI: designware: Wait for iATU enable
>   PCI: designware: Add iATU Unroll feature
>   PCI: designware: Check LTSSM training bit before deciding link is up
>   PCI: designware: Keep viewport fixed for IO transaction if
>     num_viewport > 2
>   PCI: designware: Exchange viewport of `MEMORYs' and `CFGs/IOs'
>   PCI: designware: Rename dw_pcie_valid_config() to
>     dw_pcie_valid_device()
>   PCI: designware: Simplify dw_pcie_readl_unroll(),
>     dw_pcie_writel_unroll()
>   PCI: designware: Simplify pcie_host_ops.readl_rc() and .writel_rc()
>     interfaces
>   PCI: designware: Swap order of dw_pcie_writel_rc() reg/val arguments
>   PCI: designware: Export dw_pcie_readl_rc(), dw_pcie_writel_rc()
>   PCI: designware: Uninline register accessors
>   PCI: designware: Swap order of dw_pcie_writel_unroll() reg/val
>     arguments
>   PCI: designware: Check for iATU unroll only on platforms that use ATU
>   PCI: dwc: designware: Move register defines to designware header file
>   PCI: dwc: all: Rename cfg_read/cfg_write to read/write
>   PCI: dwc: designware: Get device pointer at the start of
>     dw_pcie_host_init()
>   PCI: imx6: Add local struct device pointers
>   PCI: imx6: Removed unused struct imx6_pcie.mem_base
>   PCI: imx6: Pass struct imx6_pcie to PHY accessors
>   PCI: imx6: Pass device-specific struct to internal functions
>   PCI: imx6: Use generic DesignWare accessors
>   PCI: imx6: Reorder struct imx6_pcie
>   PCI: imx6: Port error messages for imx6_pcie_deassert_core_reset()
>   PCI: imx6: Remove unused return values
>   PCI: imx6: Factor out ref clock enable
>   PCI: imx6: Add DT property for link gen, default to Gen1
>   PCI: imx6: Remove redundant "Link never came up" message
>   PCI: imx6: Remove LTSSM disable workaround
>   PCI: dwc: all: Split struct pcie_port into host-only and core
>     structures
>   PCI: dwc: designware: Parse "num-lanes" property in dw_pcie_setup_rc()
>   PCI: dwc: designware: Fix style errors in pcie-designware.c
>   PCI: dwc: Split pcie-designware.c into host and core files
>   PCI: dwc: all: Modify dbi accessors to take dbi_base as argument
>   PCI: dwc: all: Modify dbi accessors to access data of 4/2/1 bytes
>   PCI: dwc: designware: Move _unroll configurations to a separate
>     function
>   PCI: dwc: designware: Test PCIE_ATU_ENABLE bit specifically
>   PCI: dwc: designware: Make dw_pcie_prog_*_atu_unroll() static
>   PCI: Fix typos and whitespace errors
>   PCI: Add SPDX GPL-2.0 to replace GPL v2 boilerplate
>   PCI: dwc: Replace lower into upper case characters
>   PCI: dwc: designware: Handle ->host_init() failures
>   PCI: dwc: Add accessors for write permission of DBI
>   PCI: dwc: Enable write permission for Class Code, Interrupt Pin
>     updates
>   PCI: dwc: Fix enumeration end when reaching root subordinate
>   PCI: dwc: Small computation improvement
>   PCI: dwc: Constify dw_pcie_host_ops structures
>
>  drivers/pci/Makefile               |   2 +-
>  drivers/pci/pci-imx6.c             | 368 +++++++++---------
>  drivers/pci/pci-mvebu-phy.c        |   5 +-
>  drivers/pci/pci-mvebu.c            |   5 +-
>  drivers/pci/pci-mvebu.h            |   5 +-
>  drivers/pci/pci-tegra.c            |  13 +-
>  drivers/pci/pcie-designware-host.c | 416 +++++++++++++++++++++
>  drivers/pci/pcie-designware.c      | 580 ++++++++---------------------
>  drivers/pci/pcie-designware.h      | 188 ++++++++--
>  9 files changed, 906 insertions(+), 676 deletions(-)
>  create mode 100644 drivers/pci/pcie-designware-host.c
>
> --
> 2.19.1
>

_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox

  parent reply	other threads:[~2019-01-07 22:56 UTC|newest]

Thread overview: 68+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-12-17  5:18 Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 01/65] PCI: desginware: Remove bogus prototypes Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 02/65] PCI: designware: Consolidate outbound iATU programming functions Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 03/65] PCI: designware: Use iATU0 for cfg and IO, iATU1 for MEM Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 04/65] PCI: designware: Fix PORT_LOGIC_LINK_WIDTH_MASK Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 05/65] PCI: designware: Use exact access size in dw_pcie_cfg_read() Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 06/65] PCI: designware: Simplify dw_pcie_cfg_read/write() interfaces Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 07/65] PCI: designware: Require config accesses to be naturally aligned Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 08/65] PCI: designware: Make "num-lanes" an optional DT property Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 09/65] PCI: designware: Ensure ATU is enabled before IO/conf space accesses Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 10/65] PCI: designware: Simplify control flow Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 11/65] PCI: designware: Make config accessor override checking symmetric Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 12/65] PCI: designware: Explain why we don't program ATU for some platforms Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 13/65] PCI: imx6: Move link up check into imx6_pcie_wait_for_link() Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 14/65] PCI: designware: Add generic dw_pcie_wait_for_link() Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 15/65] PCI: designware: Add default link up check if sub-driver doesn't override Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 16/65] PCI: designware: Move Root Complex setup code to dw_pcie_setup_rc() Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 17/65] PCI: designware: Remove incorrect RC memory base/limit configuration Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 18/65] PCI: designware: Return data directly from dw_pcie_readl_rc() Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 19/65] PCI: designware: Move link wait definitions to .c file Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 20/65] PCI: designware: Wait for iATU enable Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 21/65] PCI: designware: Add iATU Unroll feature Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 22/65] PCI: designware: Check LTSSM training bit before deciding link is up Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 23/65] PCI: designware: Keep viewport fixed for IO transaction if num_viewport > 2 Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 24/65] PCI: designware: Exchange viewport of `MEMORYs' and `CFGs/IOs' Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 25/65] PCI: designware: Rename dw_pcie_valid_config() to dw_pcie_valid_device() Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 26/65] PCI: designware: Simplify dw_pcie_readl_unroll(), dw_pcie_writel_unroll() Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 27/65] PCI: designware: Simplify pcie_host_ops.readl_rc() and .writel_rc() interfaces Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 28/65] PCI: designware: Swap order of dw_pcie_writel_rc() reg/val arguments Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 29/65] PCI: designware: Export dw_pcie_readl_rc(), dw_pcie_writel_rc() Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 30/65] PCI: designware: Uninline register accessors Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 31/65] PCI: designware: Swap order of dw_pcie_writel_unroll() reg/val arguments Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 32/65] PCI: designware: Check for iATU unroll only on platforms that use ATU Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 33/65] PCI: dwc: designware: Move register defines to designware header file Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 34/65] PCI: dwc: all: Rename cfg_read/cfg_write to read/write Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 35/65] PCI: dwc: designware: Get device pointer at the start of dw_pcie_host_init() Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 36/65] PCI: imx6: Add local struct device pointers Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 37/65] PCI: imx6: Removed unused struct imx6_pcie.mem_base Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 38/65] PCI: imx6: Pass struct imx6_pcie to PHY accessors Andrey Smirnov
2018-12-17  5:18 ` [PATCH v2 39/65] PCI: imx6: Pass device-specific struct to internal functions Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 40/65] PCI: imx6: Use generic DesignWare accessors Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 41/65] PCI: imx6: Reorder struct imx6_pcie Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 42/65] PCI: imx6: Port error messages for imx6_pcie_deassert_core_reset() Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 43/65] PCI: imx6: Remove unused return values Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 44/65] PCI: imx6: Factor out ref clock enable Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 45/65] PCI: imx6: Add DT property for link gen, default to Gen1 Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 46/65] PCI: imx6: Remove redundant "Link never came up" message Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 47/65] PCI: imx6: Remove LTSSM disable workaround Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 48/65] PCI: dwc: all: Split struct pcie_port into host-only and core structures Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 49/65] PCI: dwc: designware: Parse "num-lanes" property in dw_pcie_setup_rc() Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 50/65] PCI: dwc: designware: Fix style errors in pcie-designware.c Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 51/65] PCI: dwc: Split pcie-designware.c into host and core files Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 52/65] PCI: dwc: all: Modify dbi accessors to take dbi_base as argument Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 53/65] PCI: dwc: all: Modify dbi accessors to access data of 4/2/1 bytes Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 54/65] PCI: dwc: designware: Move _unroll configurations to a separate function Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 55/65] PCI: dwc: designware: Test PCIE_ATU_ENABLE bit specifically Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 56/65] PCI: dwc: designware: Make dw_pcie_prog_*_atu_unroll() static Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 57/65] PCI: Fix typos and whitespace errors Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 58/65] PCI: Add SPDX GPL-2.0 to replace GPL v2 boilerplate Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 59/65] PCI: dwc: Replace lower into upper case characters Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 60/65] PCI: dwc: designware: Handle ->host_init() failures Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 61/65] PCI: dwc: Add accessors for write permission of DBI Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 62/65] PCI: dwc: Enable write permission for Class Code, Interrupt Pin updates Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 63/65] PCI: dwc: Fix enumeration end when reaching root subordinate Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 64/65] PCI: dwc: Small computation improvement Andrey Smirnov
2018-12-17  5:19 ` [PATCH v2 65/65] PCI: dwc: Constify dw_pcie_host_ops structures Andrey Smirnov
2019-01-07 22:55 ` Andrey Smirnov [this message]
2019-01-08 15:31   ` [PATCH v2 00/65] PCI i.MX6/DesignWare sync up with 4.20-rc1 Sascha Hauer

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAHQ1cqE4Yw42KROoddZ_1OabhwN7jrutbA_u3LDGkgJrz1X=DA@mail.gmail.com' \
    --to=andrew.smirnov@gmail.com \
    --cc=barebox@lists.infradead.org \
    --cc=s.hauer@pengutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox