mail archive of the barebox mailing list
 help / color / mirror / Atom feed
From: Andrey Smirnov <andrew.smirnov@gmail.com>
To: Sascha Hauer <s.hauer@pengutronix.de>
Cc: Barebox List <barebox@lists.infradead.org>
Subject: Re: [PATCH v2 07/17] drivers: Introduce dev_set_name()
Date: Thu, 11 Oct 2018 19:01:10 -0700	[thread overview]
Message-ID: <CAHQ1cqFg-q5LSeNfNHzAnY0QE3y-443WjxOgNMCmjeiMYueJiA@mail.gmail.com> (raw)
In-Reply-To: <20181011085656.vbjx3cnh5v2s5k5m@pengutronix.de>

On Thu, Oct 11, 2018 at 1:56 AM Sascha Hauer <s.hauer@pengutronix.de> wrote:
>
> On Tue, Oct 09, 2018 at 07:57:27PM -0700, Andrey Smirnov wrote:
> > On Tue, Oct 9, 2018 at 10:38 AM Andrey Smirnov <andrew.smirnov@gmail.com> wrote:
> > > diff --git a/drivers/base/driver.c b/drivers/base/driver.c
> > > index c43a4bde2..c25498bf4 100644
> > > --- a/drivers/base/driver.c
> > > +++ b/drivers/base/driver.c
> > > @@ -468,16 +468,57 @@ EXPORT_SYMBOL(dummy_probe);
> > >
> > >  const char *dev_id(const struct device_d *dev)
> > >  {
> > > -       static char buf[MAX_DRIVER_NAME + 16];
> > > +       static char *buf;
> > > +       int err;
> > > +
> > > +       if (buf)
> > > +               free(buf);
> >
> > Ugh, I just realized that original implementation of this function
> > didn't work right for constructs like
> >
> > https://git.pengutronix.de/cgit/barebox/tree/drivers/mci/mci-core.c#n1826
> >
> > because the result of calling dev_name() for one of the arguments
> > would get clobbered by the call to dev_name() inside of dev_info().
> > Switching to heap allocated memory only makes things worse.
> >
> > Sascha, one solution for this that I can see is to just return
> > dev->name for the case of dev->id == DEVICE_ID_SINGLE and add a
> > "_name" field to struct device_d that can be lazily filled with device
> > name + ID string for dev->id != DEVICE_ID_SINGLE and returned as
> > result.
>
> Not sure if "name" and "_name" are good names, but generally I think we
> can do it that way.

OK, I'll call them "name" and "unique_name" correspondingly them and
let you fix it up when applying if you have something better in mind.

> Could you split this patch up into two and in the first one just add a
> dev_set_name function which sprintf() into the string array and converts
> the users and only in the second patch do the conversion to an allocated
> dev->name?
>

Sure, sounds good. Will do in v3.

Thanks,
Andrey Smirnov

_______________________________________________
barebox mailing list
barebox@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/barebox

  reply	other threads:[~2018-10-12  2:01 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-10-09 17:37 [PATCH v2 00/17] MV88E6xxx switch family support Andrey Smirnov
2018-10-09 17:37 ` [PATCH v2 01/17] ARM: Do not expose ARMv8 functions on ARMv7 Andrey Smirnov
2018-10-09 17:37 ` [PATCH v2 02/17] clocksource: Add ARM global timer support Andrey Smirnov
2018-10-11  8:28   ` Sascha Hauer
2018-10-09 17:37 ` [PATCH v2 03/17] VFxxx: Select CLOCKSOURCE_ARM_GLOBAL_TIMER Andrey Smirnov
2018-10-09 17:37 ` [PATCH v2 04/17] i.MX: Move GPT driver to drivers/clocksource Andrey Smirnov
2018-10-09 17:37 ` [PATCH v2 05/17] clocksource: Introduce ARCH_HAS_IMX_GPT Andrey Smirnov
2018-10-09 17:37 ` [PATCH v2 06/17] of: Demote "Bad cell count for" to debug Andrey Smirnov
2018-10-09 17:37 ` [PATCH v2 07/17] drivers: Introduce dev_set_name() Andrey Smirnov
2018-10-10  2:57   ` Andrey Smirnov
2018-10-11  8:56     ` Sascha Hauer
2018-10-12  2:01       ` Andrey Smirnov [this message]
2018-10-10  9:41   ` Lucas Stach
2018-10-10 15:33     ` Andrey Smirnov
2018-10-09 17:37 ` [PATCH v2 08/17] linux: string: Port kbasename() Andrey Smirnov
2018-10-11  8:31   ` Sascha Hauer
2018-10-13 20:47     ` Andrey Smirnov
2018-10-09 17:37 ` [PATCH v2 09/17] of: Port latest of_device_make_bus_id() implementation Andrey Smirnov
2018-10-10 16:51   ` Lucas Stach
2018-10-10 16:54     ` Andrey Smirnov
2018-10-09 17:37 ` [PATCH v2 10/17] mdio_bus: Fix documentation for mdio_bus_match() Andrey Smirnov
2018-10-09 17:37 ` [PATCH v2 11/17] include: linux: phy: Add missing PHY_INTERFACE_* constants Andrey Smirnov
2018-10-09 17:38 ` [PATCH v2 12/17] include: linux: ethtool: Add missing *_UNKNOWN constants Andrey Smirnov
2018-10-09 17:38 ` [PATCH v2 13/17] net: phy: Check phy_mask in get_phy_device() Andrey Smirnov
2018-10-09 17:38 ` [PATCH v2 14/17] mdio_bus: Allow for non PHY-devices on MDIO buses Andrey Smirnov
2018-10-09 17:38 ` [PATCH v2 15/17] net: phy: Add basic driver for MV88E6XXX switches from Marvell Andrey Smirnov
2018-10-09 17:38 ` [PATCH v2 16/17] net: phy: mv88e6xxx: Port EEPROM support code Andrey Smirnov
2018-10-09 17:38 ` [PATCH v2 17/17] net: phy: mv88e6xxx: Add support for MAC ports Andrey Smirnov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAHQ1cqFg-q5LSeNfNHzAnY0QE3y-443WjxOgNMCmjeiMYueJiA@mail.gmail.com \
    --to=andrew.smirnov@gmail.com \
    --cc=barebox@lists.infradead.org \
    --cc=s.hauer@pengutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox